forked from felixonmars/archriscv-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
1 changed file
with
6 additions
and
8 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,27 +1,25 @@ | ||
diff --git PKGBUILD PKGBUILD | ||
index 60c72d0..70f009d 100644 | ||
--- PKGBUILD | ||
+++ PKGBUILD | ||
@@ -12,10 +12,9 @@ pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load a | ||
arch=('x86_64') | ||
url="https://github.com/flightlessmango/MangoHud" | ||
license=('MIT') | ||
-makedepends=('appstream' 'cmocka' 'glfw-x11' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako') | ||
+makedepends=('appstream' 'cmocka' 'glfw-x11' 'glslang' 'meson' 'nlohmann-json' 'python-mako') | ||
depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'spdlog' 'vulkan-icd-loader') | ||
-makedepends=('appstream' 'cmocka' 'git' 'glfw-x11' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako') | ||
+makedepends=('appstream' 'cmocka' 'git' 'glfw-x11' 'glslang' 'meson' 'nlohmann-json' 'python-mako') | ||
depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python' 'python-matplotlib' 'python-numpy' 'vulkan-icd-loader') | ||
-optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl' | ||
- 'glfw-x11: Required for MangoApp' | ||
+optdepends=('glfw-x11: Required for MangoApp' | ||
'gamescope: Use MangoApp as an overlay within gamescope') | ||
replaces=("$pkgname-common" "$pkgname-common-wayland" "$pkgname-common-x11" "mangoapp" "$pkgname-x11" "$pkgname-wayland") | ||
conflicts=("$pkgname-common" "$pkgname-common-wayland" "$pkgname-common-x11" "mangoapp" "$pkgname-x11" "$pkgname-wayland") | ||
@@ -44,7 +43,8 @@ build() { | ||
-Duse_system_spdlog=enabled \ | ||
@@ -34,7 +33,8 @@ build() { | ||
arch-meson "$_pkgname-v$_tarpkgver" build \ | ||
-Dmangoapp=true \ | ||
-Dmangohudctl=true \ | ||
- -Dmangoapp_layer=true | ||
+ -Dmangoapp_layer=true \ | ||
+ -Dwith_xnvctrl=disabled | ||
+ -Dwith_xnvctrl=disabled | ||
|
||
meson compile -C build | ||
} |