This repository has been archived by the owner on Oct 29, 2024. It is now read-only.
generated from Program-Learning/nur-packages-template
-
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Initial commit for Adobe_Illustrator_CS6.AppImage
- Loading branch information
1 parent
a91f85b
commit d4a9842
Showing
4 changed files
with
66 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
62 changes: 62 additions & 0 deletions
62
pkgs/Adobe_Illustrator_CS6.AppImage/Adobe_Illustrator_CS6.AppImage.nix
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
{ fetchurl, lib, stdenv, pkgs, appimage-run, makeDesktopItem }: | ||
stdenv.mkDerivation rec { | ||
pname = "Adobe_Illustrator_CS6"; | ||
version = "CS6"; | ||
|
||
src = fetchurl { | ||
url = | ||
"https://github.com/Program-Learning/nur-packages/releases/download/Adobe_Illustrator_CS6.AppImage/Adobe_Illustrator_CS6.AppImage.7z"; | ||
sha256 = "sha256-U19wx0asTuu6o/AvUrp2AM1bywwJAfH5R7H4zdVPj+A="; | ||
}; | ||
sourceRoot = "."; | ||
|
||
nativeBuildInputs = with pkgs; [ | ||
wrapGAppsHook | ||
autoPatchelfHook | ||
makeWrapper | ||
dpkg | ||
]; | ||
|
||
unpackPhase = "7z x $src"; | ||
|
||
installPhase = '' | ||
_install() { | ||
mkdir -p $out/Appimage | ||
mv Adobe_Illustrator_CS6.AppImage $out/Appimage/ | ||
} | ||
_install | ||
''; | ||
|
||
buildInputs = with pkgs; [ p7zip ]; | ||
|
||
# runtimeLibs = pkgs.lib.makeLibraryPath [ | ||
# pkgs.libudev0-shim | ||
# pkgs.glibc | ||
# pkgs.libsecret | ||
# pkgs.nss | ||
# ]; | ||
|
||
preFixup = '' | ||
makeWrapper ${appimage-run}/bin/appimage-run $out/bin/adobe_illustrator_cs6 \ | ||
--argv0 "adobe_illustrator_cs6" \ | ||
--add-flags "$out/Appimage/Adobe_Illustrator_CS6.AppImage" | ||
''; | ||
|
||
desktopItems = lib.toList (makeDesktopItem { | ||
name = "Adobe_Illustrator_CS6"; | ||
genericName = "Adobe_Illustrator_CS6"; | ||
exec = "photoshop"; | ||
icon = "photoshop"; | ||
comment = "Adobe_Illustrator_CS6"; | ||
mimeTypes = [ "x-scheme-handler/wechatide" ]; | ||
desktopName = "Adobe_Illustrator_CS6"; | ||
categories = [ "Development" ]; | ||
}); | ||
meta = with lib; { | ||
description = "Adobe_Illustrator_CS6"; | ||
homepage = "https://t.me/Linux_Appimages/1052"; | ||
license = licenses.unfree; | ||
platforms = [ "x86_64-linux" ]; | ||
maintainers = with maintainers; [ Program-Learning ]; | ||
}; | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
import ./Adobe_Illustrator_CS6.AppImage.nix |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters