Replies: 3 comments 1 reply
-
My 2cent: I think calibrate should be separate than process since in my mind this is the unifying function that converts the various data types to a uniform model before passing to other process functions. |
Beta Was this translation helpful? Give feedback.
-
I don't know about others, but as far as I'm concerned you are the expert here 😉. I don't think there is a right or wrong answer about whether calibration is "processing". On an additional note, it looks like you're shifting from the pattern of # From this
ed = Process('path_to_a_converted_file')
ed.calibrate()
# To this
echodata = EchoData('path_to_a_converted_file')
Sv = ep.calibrate.get_Sv(echodata) I'm not saying one is better than the other. But it is a change. The new pattern is also a departure from the way Also, while previously "get Sv" was effectively what |
Beta Was this translation helpful? Give feedback.
-
Alright, folks, after the fun discussions last week, here's what we decided:
Anything I missed here? |
Beta Was this translation helpful? Give feedback.
-
I wanted to get some inputs on how the syntax should be for calibration calls with our new EchoData object in the upcoming v0.5.0. I think this will set the pattern for how we add more data processing/analysis functions later (especially since we're going to have breaking changes in the API calls (even though we can make it backward compatible), so want to be a little careful.
Let's use calibration to obain Sv as an example.
To create an EchoData object, one would do
To calibrate the raw data in this file, we can do
Or we can group calibrate to under process and do
It boils down to if we consider calibration to be part of "processing", but I feel more modularization would be better in the long run, since there are so many ways to "process" data. It almost seems that one should avoid that module name altogether. For example, a processing could be school detection that can be called by:
instead of
Right now I structured the code to do Option 1.
@emiliom @valentina-s @lsetiawan @ngkavin @imranmaj : any suggestions welcome! Thanks!
Beta Was this translation helpful? Give feedback.
All reactions